AVR ATtiny85 jungfräulich machen?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hallo ceperiga,

      ja, die wurden auf Ext. = 0xFE, High = 0xD5, Low = 0xC1 gesetzt! 8MHz int. mit Bootlader. Irgendwie bekomme ich das Brennen nicht richtig hin! Ich hab hier zum Brennen den USB-AVR910 und das selbstgebaute Grafik Tool von Jens Gürtler, ist vielleicht bekannt! Eigentlich hab ich noch nie Probleme damit gehabt und alles hinbekommen, nur bei diesem Projekt bekomme ich echt Pickel! Mit Erase Chip bin ich noch nicht in Berührung gekommen.

      Klaus
    • Hallo tschoeatsch,

      das wären die Default Werte, das weis ich, danke aber für den Hinweis. Nur bin ich mir absolut nicht sicher bei dem Refreschen des Chips. Ich weis nicht wie ich das anstellen soll! Meine Möglichkeiten die ich hier habe sind ziemlich beschränkt, da wäre z.B.:
      PonyProg und den ISP-PonyProg

      Wobei ich zugeben muss, PonyProg hab ich bis jetzt nur einmal benutzt zum fertigen des AVR910, danach nur noch Bascom und das Grafik Tool. Erase Chip lag bis jetzt absolut nicht an, braucht man in der Regel ja auch nicht oder? Weis denn jemand, wie ich z.B. mit PonyProg vorgehen müsste um den Chip zu löschen, denn nur darum geht es! Ich könnte mir auch bei Reichelt neue Tinys kaufen, das fänd ich allerdings nicht so gut.

      Klaus
    • Hallo,
      ich hab mich gestern Abend mit dem Programm etwas intensiver beschäftigt und auch herausgefunden warum die Default Programmierung des Tinys85 nicht funktioniert. Das Löschen des Chips an sich funktioniert, was aber nicht gelöscht wird, das ist der EEProm Bereich! Da bin ich noch nicht dahinter gekommen, wie ich den Bereich gelöscht bekomme. Das es bei dem Grafik Tool von Jens keine Chip Lösch Möglichkeit gibt, war bis jetzt eigentlich kein Grund es nicht zu benutzen! Alles was ich bis heute an Projekten hatte (und das waren nicht wenige), konnte ich wunderbar damit in die verschiedensten Chips brennen. Das ich nun vor dem Problem stehe, dass ich diesen Tiny85 Cleanen muss, wird wohl auch das Einzige Mal sein dass ich das machen muss! :) Den BitBurner hab ich mir mal runtergeladen, den Guck ich mir mal an.

      Klaus
    • veryoldman wrote:

      aber nicht gelöscht wird, das ist der EEProm Bereich
      Das passiert im Normalfall mit dem Erase Chip. (Welches vor jedem Brennen ausgeführt wird) Das kann nur verhindert werden wenn das Fuse High Bit 3 =EESAVE gelöscht wird.
      Bei Pony sind die Fuse Bytes hinter dem Vorhängeschloß-Symbol oder Command - Security and Configuration Bits.
      Der HV-Brenner löscht auch alles und setzt die Fuses richtig. (Alles Fuses?)
    • Hallo,

      bevor ich überhaupt den Versuch gemacht habe den Chip zu löschen, habe ich die Fuses wieder in den Default Zustand gesetzt. Dann habe per PonyProg den Flash und den EEProm Bereich gelöscht und anschliessend mit FF überschrieben! Mehr geht doch eigentlich nicht um den Chip wieder in die Jungfräulichkeit zu versetzen? Ich habe mir die Bereiche im Chip angeschaut und festgestellt, dass alles mit FF gefüllt war.
      Ich kenn mich mit AVR-Studio nicht aus, deshalb hab ich auf PonyProg zurückgegriffen und ich muss sagen, das Programm (neueste Version und in deutscher Sprache :) ) gefällt mir außerordentlich.

      Gruß
      Klaus