Frage zu einer WS2812-"Platine"

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Frage zu einer WS2812-"Platine"

      Ich habe da drei von diesen LEDs für mein erstes WS2812 Projekt.
      Nachdem das aber nicht funktionierte habe ich mal zu suchen angefangen (natürlich zuerst im Code der aus der Hilfe stammt) :D .

      Nachdem ich einen "normalen" 8er-Streifen verwendete, und das Programm aber funktionierte habe ich den Fehler auf der kleinen Platine zu suchen begonnen und erst mal den Schaltplan dazu reengineered und bin jetzt etwas verwirrt.
      Dabei habe ich auch den eigentlichen Fehler entdeckt. Es war nämlich ausgerechnet bei der ersten Platine die Durchkontaktierung von "Din" defekt. Dadurch konnte das auch nicht funktionieren. Nach Reparatur der Durchkontaktierung funktioniert die Schaltung erst mal.
      Was ich mich aber frage, wofür ist der 75 Ohm Widerstand in der Versorgungsleitung?
      Laut Datenblatt ist der eigentlich nicht da. Oder ist das wieder ein spezielles CE (China Engineering) weil der eher ins Din gehören könnte a_38_b45e201d .
      WS2812.JPG
    • Es sind mal 12V stripes mit den ws2812 rumgegeistert, das ist vielleicht die Schaltung dazu. Ich hab die immer, wie im Datenblatt, direkt mit 5V betrieben. Achtung, die Leds sind mit einer eher 'wabbeligen' Masse ausgegossen. Wenn man blöd drauf drückt, können wohl die bond-Drähtchen abreisen. Ist mir zumindest schon passiert.

      Der Widerstand ist doch ungünstig, weil jetzt die Spannung an der Led von den Ledströmen abhängt. Am Din wäre er nicht verkehrt, aber eigentlich auch nur am Anfang, zwischen den Leds auch wieder nicht nötig.


      In deinem link steht ja auch:
      Also include a precision internal oscillator and a 12V voltage programmable constant curre-nt control part, effectively ensuring the pixel point light color height consistent.
      Da tauchen die 12V auch auf.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von tschoeatsch ()

    • Ich denke eigentlich auch, dass der Widerstand bei 5V UB kontraproduktiv ist.
      Ich werde den überbrücken, vor allem weil ich im Anwendungsfelder nur 5V habe.
      Aber auch bei einer höheren Spannung kann das doch eigentlich nicht OK sein.
      Weil ja abhängig davon wieviel LEDS von dem Chip gleichzeitig leuchten, die sich gegenseitig beeinflussen werden. Das kann doch IMHO der Chip nicht ausgleichen.
    • 4791 schrieb:

      die Stromversorgung der WS2812 sollte mit 1000µF gestützt werden. Ist der Elko paralell zum 100n geschaltet wird mit dem 75 Ohm- Widerstand der Einschaltstrom begrenzt.
      Das ist bei den Platinchen nicht vorgesehen. Wenn man das Datenblatt anschaut, findet man das
      ws2812.PNG
      und das passt dann garnicht zu einem Serienwiderstand. Welche Spannung liegt denn an der Ws2812 an, wenn keine Led drin leuchtet? Deutlich über den max. ratings.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------
    • Ich habe das viermal kontrolliert, weil ich es auch nicht glauben konnte :D .
      Aber der Widerstand hat mit dem einen Anschluss eine direkte Verbindung mit +UB der Platine und geht mit dem zweiten an den LED-Anschluss für +UB.
      Oder anders ausgedrückt, keiner von den vier Anschlüssen der LED hat eine direkte Verbindung mit dem +UB-Eingang der Platine, während der Din Eingang und der Minus-Anscluss der Platine eine direkte Verbindung mit den passenden Anschlüssen der LED hat.
      Der Kondensator liegt an Minus und am +UB-Eingang der LED (also nach dem Widerstand). Mehr Bauteile hat diese kleine Platine dann auch nicht.
    • Zitronenfalter schrieb:

      wofür ist der 75 Ohm Widerstand in der Versorgungsleitung?
      Der Widerstand ist in den 6-poligen Varianten des WS2812 in der Versorgung des Logikteils und soll dort wohl Störungen unterdrücken (zusammen mit dem Kondensator)

      In dieser Schaltung hier könnte der Widerstand dazu dienen, die Helligkeit zu kompensieren. Weil wenn alle 3 LEDs leuchten ist es heller, als wenn nur eine leuchtet. Am Widerstand fällt dann soviel Spannung ab, bis der Chip nur noch 3 V bekommt und die LED abschaltet ( etwa 27 mA). Vielleicht kannst du mal messen, was an Spannung am Chip noch ankommt, wenn eine oder alle Farben an sind.
    • Ich gehe inzwischen auch von einem Designfehler aus und werde den Widerstand wohl überbrücken.
      Wenn man in den weiten des Netzes nach diesen "Pillen" sucht, findet man (zumindest nach den Bildern) nur solche mit diesem Widerstand, während alle anderen diesen nicht aufweisen.
      Es gibt ja durchaus auch Platinen mit den von mir gesuchten Anordnung (2x4) zur Beleuchtung eines lasergravierten Acrylblockes, nur kommen die nicht mehr rechtzeitig. Daher muss ich auf diese zurückgreifen.
    • Und was soll ich sagen, heute angekommen und haben auch den Widerstand verbaut (am Bild im ebay-Link oben ist da aber keiner) :rolleyes: .
      Gehört der jetzt dahin oder nicht (ich würde eher meinen eher nicht)?
      Weil warm werden die schon mit dem Widerstand.
      Allerdings sind auf den achtfach-Streifen oder den runden die ich auch hier habe auch keine Widerstände verbaut und ich denke der Chip sorgt doch für korrekte Ströme.
    • Ich kenn's nur ohne. Aus meiner Sicht ist der deplatziert. Im Datenblatt findet sich der auch nicht. Wenn ich jetzt zB. eine voll leuchtende Led mit dann 2,9V am chip hab' und die nächst folgende leuchtet nicht und hat somit 5V am chip, das sind doch Pegelunterschiede, die tragen doch nicht zur Betriebssicherheit bei. Probier's einfach mit dem R aus, wenn alles geht und die Helligkeit stimmt, dann ist es gut und du sparst dir das lästige Fummeln.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------
    • Funktionieren tut es ja auch mit dem Widerstand soweit ich das hier in meiner Anwendung sehe.
      Ich habe mal den 8er-Streifen neben den Pillen parallel betrieben und sehe soweit schon einen (wenn auch kleinen aber eben auch sichtbaren) Unterschied in der Helligkeit.
      Nur habe ich die LEDs mit einem Papierstreifen abgedeckt, weil sonst wird man da ja Blind und meine Netzhaut hat auch ohne LEDs den einen oder anderen Schaden :D .
      Unterschiede kann man IMHO nur messen nur habe ich keinen Lichtmesser ^^ .
    • Ich habe die Widerstände inzwischen entfernt (ging einfacher als gedacht) und die Pads überbrückt.
      Funktioniert bisher 1A.
      Dem Verkäufer habe ich auch geschrieben. Mal sehen ob da was kommt.

      Inzwischen habe ich auch weiter gesucht und auch welche gefunden mit 27 Ohm Widerstand.
      Das eigenartige ist halt, dass auf allen Platinen wo mehr als eine LED verbaut ist (auch auf den 8x8 und noch größer), kein Widerstand drauf ist sondern eben nur auf den "Pillen".
    • Inzwischen hat auch der Verkäufer der neuen "Pillen"geantwortet.
      Und was soll ich sagen, bei diesen "Pillen" liegt der Widerstand in der Di-Leitung (wo er auch Sinn macht).
      Das habe ich natürlich nicht mehr kontrolliert, nach dem ich hier zwei Lieferungen habe, wo der Widerstand in der Plus-Leitung der Stromversorgung liegt.
      Von daher also ganz klar ein Designfehler dass man nicht mal drei Bauteile richtig platzieren und verbinden kann :rolleyes: )
      Ich versteh nur nicht, warum nur immer ich diese Fehler finde die ich gar nicht suche ?( .
      Weil offen bar bin ich wieder der einzige dem so etwas überhaupt aufgefallen ist, weil mit Google finde ich dazu nur diesen Threat :D .
      Warum dann aber auf den Mehrfachplatinen nicht zumindest ein Widerstand drauf ist, erschließt sich mir auch nicht.
      Bleibt nur zu hoffen, dass diese falschen Platinen bald alle aufgebraucht sind und in die Lager nur mehr richtig bestückte Platinen kommen.
    • Äh, das 'tschoeatsch gefällt das' soll keine Schadenfreude ausdrücken! Ne, garnicht. Nur vielleicht ein ganz klein wenig, aber wirklich nur ganz ganz wenig.
      Die anderen Einzelplatinen richten sich halt nach dem Datenblatt, da steht nix von Widerstand in DIN-Leitung. Der ist ja, so wie ich das sehe, nur als Schutz der ersten Led gedacht. Drum wäre das bei stripes Verschwendung, weil die ja nach jeder Led abschnippelbar sind und somit jede Led die erste werden kann. Das machen aber die wenigsten.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------