SIM800L

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Tamu wrote:

      Hab mal 16Mhz-Quarze bestellt.
      Wenn du mit serieller Übertragung spekulierst, solltest du besser sogenannte Baudratenquarze einsetzen.
      also z.B 7372800Mhz, 11059200MHz oder 14745600Mhz.
      Mit denen ist die Fehlerrate bis zu 230400BpS (natürlich nur in den dazwischenliegenden gängigen Abstufungen) fehlerfrei also 0%.
      Mit 16000000MHz ist nur 1200BpS bei 0% alles andere ist Fehlerbehaftet und müsste dann eigentlich im Programm entsprechend abgehandelt werden wenn es zu einer wirklich sicheren Übertragung zwischen den Komponenten kommen soll.
    • New

      Hallo Cable oder Jemand,
      Hab noch nichts zum Testen und betrachte deinen Code (1).
      Meine Frage dazu:
      Braucht man die Übertragungs-Pins TXD und RXD an Port PD1 und Port PD0
      nicht zu konfigurieren ?
      Ich finde wenigstens keine Stelle im Code wo das geschied.
      Gruß
      Jürgen
    • New

      Chr(Byte) schreibt ein Zeichen was sich nicht normal darstellen läßt wie Steuerzeichen
      Chr(13)=Cr=Enter, Chr(26) =Substitude und Chr(34) ist ein "

      Im Datenblatt des Sim sollte das benötigte Protokoll stehen. Also welche Befehle es gibt und in welcher Form sie übermittelt werden müssen.

      Eine Übersicht der Steuerzeichen gibt in Ascii-Tabellen. Google, das findet hunderte mehr oder weniger hübsch gemacht, jedoch mit dem selben Inhalt. In der Bascom Hilfe ist auch eine Help/Index/Ascii chart

      The post was edited 1 time, last by Pluto25 ().

    • New

      Tamu wrote:

      Das "Chr" sagt also dem Progamm ,das es das Zeichen (aus Ascii) in
      der Klammer verarbeiten soll--liege ich da richtig?
      naja, verarbeiten trifft es nicht ganz, eher benutzen.
      chr(x) ist ein Zeichen vom Typ String, wobei x für das entsprechende Zeichen aus der Ascii Tabelle steht.

      Beispiel: chr(65) ist genau daselbe wie "A"

      Je nach verwendeter Ascii-Tabelle unterscheiden sich die Zeichen ab chr(128), da gibt es Sonderbuchstaben wie ä ö, ü oder bei manchen Displays auch japanische Zeichen.

      @Tamu
      Es wäre nett, wenn Thread-fremde Themen in eigenen, neuen Threads abgehandelt werden.
    • New

      Hallo Forum,
      seit gestern versuche ich eine SMS mit dem Sim800L
      zu versenden--klappt nicht.
      Es schien zunächst mal so, als würde alles laufen (Kontroll-Led
      Parallel zum AVR „An“ und 1Sekundentakt blinken am Sim800L)
      Aber das „1Sekundentakt blinken“ am Sim800L war
      schon das Probelm---der schaltete nicht auf den 3-Sekunden
      Takt um.Nach langem Suchen fand ich dann heraus,daß
      eine Zelle vom 2S LiPo defekt war.--LiPo gewechselt.
      Sim-Led blinkt nun ca.10 mal im 1Sek-Takt und wechselt dann
      zum 3Sek-Takt.Scheinbar hat sich der Sim800L dann ins Netz
      eingeloggt.
      Der Test dazu,ob der Sim mit dem AVR kommuniziert:
      Hab den TX vom AVR mal abgeklemmt ---dann bleibt der
      1Sek-Takt am Sim800--also keine Umschaltung auf 3Sek-Takt.
      Zum Schaltungsaufbau:
      LiPo 3s-30c>>Step Down 4A auf 4V>>AVR und Sim800L.
      Atmega8a kann laut Datenblatt mit 4V betrieben werden.
      Um event. Fehler auszuschließen , hab ich den Code von Cable
      (Beitrag1) und alles was daraus hervor geht so übernommen.
      (bis auf meine Nummer natürlich).
      D.h. Der Quarz ist 16MHz die Fuse-Bits sind auf „111111 High Freq.“
      eingestellt.
      Tx und Rx -Leitungen müssten richtig verschaltet sein denn der
      3Sek-Takt stellt sich ja ein.
      Mein „NochProblem“:
      Wenn ich jetzt den Taster drücke passiert nichts.
      (Taster geht nach Masse und int.PullUp sind eingestellt)
      Es kommt keine SMS an. (Pin am Handy ist deaktiviert)
      Meine „Noch-Frage“:
      Muß der Taster solange „Null“ bleiben bis die SMS durch ist oder
      reicht ein „Anschubsen“ mit einen kurzen „Taster-Ein“.
      Hab aber beides getestet--bekomm so oder so keine SMS.

      Gruß
      Jürgen

      The post was edited 1 time, last by Tamu ().

    • New

      Das Modul braucht den AVR nicht um sich im GSM-Netz einzubuchen.
      Eine Ausnahme mag sein, dass die SIM-Karte nicht "offen" ist und eine PIN erwartet die müsste selbstverständlich gesendet werden.

      Die LED am Modul zeigt ja eben den Zustand an
      schnelles Blinken: Einbuchvorgang am laufen
      langsames blinken: erfolgreich eingebucht.
      Diese LED könnte man aber sogar umkonfigurieren.
      Verlässlich sind da nur entweder die Abfragen die man selbst veranlassen kann oder das Mitlauschen was denn das Modul so sendet.
      Erst durch die Abfragen erhält man verlässlich Informationen was denn Sache ist.

      Speziell das Senden einer SMS ist etwas trickreich.
      Das ist eigentlich eine zweiteilige Prozedur, zuerst wird der Vorgang eingeleitet, dann muss man auf die Empfangsbereitschaft des Moduls warten und wenn dass dann der Fall ist überträgt man den zu sendenden Text der mit IMHO CHR26) abgeschlossen wird.
      Man könnte das auch "einfacher" dafür aber mit dem Risiko machen, dass es nicht funktioniert indem man den Text nach einer festen Wartezeit einfach nachträgt.

      Ich würde da erst mal empfehlen, statt dem AVR ein USB-TTL-Modul anzuschließen und mit einem Terminalprogramm zu beobachten was denn da so passiert.
      Das Modul ist nämlich sehr "gesprächig".
      Dann versteht man leichter was sich denn da so abspielt.
    • New

      Zitronenfalter wrote:

      Das Modul braucht den AVR nicht um sich im GSM-Netz einzubuchen.
      Aber in der Start-Phase müsste das Modul ja mit dem AVR kommunizieren.
      Denn, habe ich den TX abgesteckt,binkt das Sim800 im 1Sekunden-Takt
      ---vielleicht bis in alle Ewigkeit. Und ist der Tx angesteckt,blinkt es ca.10mal
      im 1Sekundentakt und geht dann über in den 3Sekunden-Takt.
      Oder weißt du was da der Zuammenhang ist ?

      Vielleicht sollte ich auf meine , seit ca.10Jahre alte ,immer funktionierende
      Alarmanlage zurückgreifen wenn das mit dem Sim800 nicht funktioiert ?
      Ich hab die damals in meiner Bascom-Anfangszeit "zusammen gestrickt"
      Ist zwar nicht auf dem hochtechnisierten Standard,aber ich hab immerhin
      8 Eingänge---benutze dazu ein "Wald-und WiesenHandy"
      (Samsung GT E1050) --hab Feldstärkeanzeige--kann das Guthaben abfragen--
      schalte die Anlage mit Hilfe des Vibrationsmotoranschlußes aus (ohne eine SMS
      zu verschicken) usw.
      Das hat natürlich auch Nachteile,die SMS kommen verschlüsselt an--nicht im Klartext.
      Das zu bauen ist auch viel mechanische Arbeit.
      Ok--mal sehen ob ich das Sim800 noch bewegen kann.
      Gruß
      Jürgen

      The post was edited 2 times, last by Tamu ().

    • New

      Zitronenfalter wrote:

      Das Modul ist nämlich sehr "gesprächig".
      Was habt Ihr für Module? :D Meins sagt immer nur 0x00 ;(
      Dann blinkt es fünfmal im Sekundentakt dann drei Sekunden Pause und wieder 0.
      Vermutlich Absturz wegen Stromnot (3v3 ,500mA max ist etwas knapp für ein Modul das >3,5V , 2A peek braucht) a_71_f9c57bbe
      @Tamu was sagts denn am PC?
      Auf ATE0 sollte es ATE0OK sagen
      auf AT+GMR sollte es seine Version verraten
      mit AT+CREG? antwortet es mit dem Verbindungsstatus (+CREG:0,0OK) ?(
      wobei in dem Fall das OK besagt das er mich verstanden hat, nicht das die Verbindung OK ist. :cursing:
      (Wie auch - ohne SIM-Card und genug Strom) ;)

      PS braucht Deine Sim Card einen Pin? Nicht das es sie sperrt weil es ihn nicht weiß.

      The post was edited 1 time, last by Pluto25 ().

    • New

      Pluto25 wrote:

      Vermutlich Absturz wegen Stromnot (3v3 ,500mA max ist etwas knapp für ein Modul das >3,5V max 2A braucht)
      Ja. da ist das Modul wohl sehr sensibel.Das war auch weshalb ich so lange gesucht habe bis ich herausfand das der Akku
      kaputt war--es blinkte immer, also dachte ich;".. es lebt noch".Ich hatte sogar nachher festgestellt,wenn ich ein Ampermeter
      dazwischen hatte , daß die Umschaltung von 1Sek-Takt auf 3Sek-Takt auch nicht funktionierte.
      Gruß
      Jürgen