Wie kann man einen Com-Port aus den Bascom-Options für den Programmer entfernen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wie kann man einen Com-Port aus den Bascom-Options für den Programmer entfernen

      Hallo zusammen!
      Das ist mein erster Post hier im Forum. Bisher war ich immer stiller Mitleser. Ich bin schon ein älteres Semester und verwende Bascom im Moment hauptsächlich für die Programmierung von Modelleisenbahnprojekten. Nur so kleine Dinge, wie flackerndes Schweißlicht, Servo, Stellpult etc.
      Ich hoffe, einer unter euch kann mir bei meinem Problem helfen.
      Ich habe einen diamex-Programmer angeschlossen. Dafür habe ich den STK500 nativ driver eingestellt. Das Flashen funktioniert damit grundsätzlich. Nur habe ich Probleme mit dem voreingestellten Com-Port.

      Com6 ist auf meinem Rechner, auch nicht in der Geräteverwaltung, nicht verfügbar/installiert. Immer wenn ich Bascom starte, wird dieser Com-Port für den Treiber eingestellt. Ich muss nun jedesmal den richtigen Com-Port (Com7) einstellen. Wie kann ich Com6 aus der Configuration löschen bzw. Bascom zwingen, Com7 anzunehmen?
      Files
    • Eigendlich speichert es den gewählten Port automatisch, geht aber auch "zu Fuß" : In der bascom-avr.xml
      Die Zeile <ATMELCOM> suchen (hier 158) und dort den Wunschport eintragen
      <ATMELCOM>COM7</ATMELCOM>
      alternativ könnte man auch den ungenutzten Port 6 freiräumen (Ausgeblendete Geräte zeigen)
    • Hallo jogiavr,
      wäre mal an Deinem Programm für ein Schweißlicht interessiert. Versuche mich
      gerade etwas umständlich an solch einem Teil mit einem ATTiny45 an einem
      Flackerlicht für eine Feuerbüchse.
      Danke und schönen Sonntag noch
      Jürgen
    • Hier habe ich dir ein Video hochgeladen: youtu.be/BwlBwcvcoqs
      Ich hoffe, das ist, was du suchst. Ich habe zwei LED Rücken-an-Rücken zusammengeklebt. Eine weiße und eine blaue. Sie werden über PWM gesteuert. An Elektronik habe ich nur einen Trimmer als Vorwiderstand für die LEDs. Ich habe versucht, einen Schweißablauf zu simmulieren. Dabei geht der Schweißer ja immer wieder mal weg von der Schweißstelle, dann bleibt er mal wieder einen gewisse Zeit dran. Dauernd das Licht auf der Anlage wollte ich auch nicht, wehalb es immer nur kurze Zeit abläuft und dann einpaar zufällige Minuten Pause macht.
      Bilder von den LED habe ich leider nicht.
      Teilweise, das möchte ich ausdrücklich betonen, habe ich Codeschnipsel und Erklärungen zu PWM aus dem Netz von mir unbekannten Autoren verwendet. Das Gesamtkonzept ist aber meine Idee, die jeder gerne kopieren kann.
      Ich hoffe, ich darf das hier so veröffentlichen.
      Files