BASCOM mag mit Lenovo YogaBook mit neuestem Win10/64bit wohl nicht.

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • BASCOM mag mit Lenovo YogaBook mit neuestem Win10/64bit wohl nicht.

      Hallo

      Ich habe eben versucht auf besagten Notebook BASCOM zu installieren.
      Der Installationsvorgang selbst funktioniert fehlerfrei.
      Ich habe auch ein Verzeichnis auf dem zweiten "Laufwerk" (na gut es ist eine SD-Karte) verwendet, damit ich von der C-platte wegkomme.

      Das Problem besteht darin, dass nachdem BASCOM gestartet wird, eine Fehlermeldungsfenster aufpopt und meint, dass BASCOM nun instabil sei.
      Nach dem wegklicken des Fensters kann man aber offenbar weiterarbeiten.
      Dennoch stört mich eine derartige Fehlermeldung aber schon.

      Das Meldungsfenster bietet die Möglichkeit, einen Log anzufertigen den ich hier mal beifüge.
      Bevor ich mich da "beschwere" frage ich mal hier ob das schon mal wer hatte oder ob das mit dem Notebook zu tun haben könnte (z.B. eine Prozessorunverträglichkeit)?

      Source Code

      1. ==============================================================================
      2. = 01.05.2018 11:33:34 =
      3. ==============================================================================
      4. There was an error during the execution of this program.
      5. The application might become unstable and even useless.
      6. It's recommended that you save your work and close this application.
      7. Device cannot be identified.
      8. ------------------------------------------------------------------------------
      9. Exception log with detailed tech info. Generated on 01.05.2018 11:33:03.
      10. You may send it to the application vendor, helping him to understand what had happened.
      11. Application title: BASCOM-AVR
      12. Application file: D:\Programme\BASCOM-AVR\bascavr.exe
      13. ------------------------------------------------------------------------------
      14. Exception class: EControllerError
      15. Exception message: Device cannot be identified.
      16. Exception address: 009F78FB
      17. ------------------------------------------------------------------------------
      18. Main thread ID = 708
      19. Exception thread ID = 708
      20. ------------------------------------------------------------------------------
      21. Exception stack
      22. Stack list, generated 01.05.2018 11:33:03
      23. (005F68F6){bascavr.exe } [009F78F6] Unknown function at madTraceProcess + $5A44A2
      24. (005F7497){bascavr.exe } [009F8497] Unknown function at madTraceProcess + $5A5043
      25. ... Viele ähnliche Zeilen ...
      26. (000BFEC6){bascavr.exe } [004C0EC6] Unknown function at madTraceProcess + $6DA72
      27. (000D8302){bascavr.exe } [004D9302] Unknown function at madTraceProcess + $85EAE
      28. (000E0E39){bascavr.exe } [004E1E39] Unknown function at madTraceProcess + $8E9E5
      29. (006765E2){bascavr.exe } [00A775E2] Unknown function at madTraceProcess + $62418E
      30. ------------------------------------------------------------------------------
      31. System : Windows 8 Workstation, Version: 6.2, Build: 23F0, ""
      32. Processor: Intel, Intel(R) Atom(TM) x5-Z8550 CPU @ 1.44GHz, 1433 MHz MMX SSE SSE2 SSE3 SSSE3 SSE41 SSE42 64 bits DEP
      33. Memory: 4010; free 2144
      34. Display : 1280x800 pixels, 32 bpp
      35. ------------------------------------------------------------------------------
      36. List of loaded modules:
      37. [00400000] D:\Programme\BASCOM-AVR\bascavr.exe
      38. 2.0.8.1 - 2.0.8.1
      39. BASCOM-AVR IDE
      40. Unit versioning information:
      41. JCL\source\common JclResources.pas 3850 2012-08-28 16:44:17 +0200 (mar. 28 août 2012)
      42. JCL\source\common JclBase.pas 3865 2012-09-05 20:00:33 +0200 (mer. 05 sept. 2012)
      43. JCL\source\windows JclWin32.pas 3796 2012-05-23 15:57:30 +0200 (mer. 23 mai 2012)
      44. JCL\source\common JclLogic.pas 3599 2011-09-03 00:07:50 +0200 (sam. 03 sept. 2011)
      45. ... Viele ähnliche Zeilen ...
      46. JCL\source\windows JclDebug.pas 3861 2012-09-04 16:08:04 +0200 (mar. 04 sept. 2012)
      47. JCL\source\common JclRTTI.pas 3759 2012-03-04 19:39:47 +0100 (dim. 04 mars 2012)
      48. JCL\source\common JclMime.pas 3599 2011-09-03 00:07:50 +0200 (sam. 03 sept. 2011)
      49. JCL\source\common $URL$ $Revision$ $Date$
      50. [01440000] D:\Programme\BASCOM-AVR\BSCAVRL.DLL
      51. <00400000> (no module version info)
      52. [01920000] D:\Programme\BASCOM-AVR\BASC-AVR.DLL
      53. <00200000> 2.0.8.1 - 2.0.8.1
      54. BASCOM-AVR Compiler
      55. [08AB0000] D:\Programme\BASCOM-AVR\SaxComm7.ocx
      56. <10000000> 7.0.0.2182 - 7, 0, 0, 2182
      57. Sax Comm Objects 7.0
      58. [10000000] D:\Programme\BASCOM-AVR\BASPDF.DLL
      59. 2.0.0.0 - 2.00
      60. PDF Reader DLL
      61. ------------------------------------------------------------------------------
      62. Active Controls hierarchy:
      63. TButton "btn_Next"
      64. Tfrm_TipOfTheDay "frm_TipOfTheDay"
      65. ------------------------------------------------------------------------------
      Display All
    • Zitronenfalter wrote:

      eine Fehlermeldungsfenster aufpopt und meint, dass BASCOM nun instabil sei
      Sowas hatte ich auch, als ich mit 2 Versionen (Demo und Voll) auf einem Rechner experimentierte. Das lag wohl an der jeweiligen Inkompatibilidität (puh!) der bascom-avr.xml im Benutzerverzeichnis. Lösch die mal, was dann passiert.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------
    • stefanhamburg wrote:

      Hast Du BASCOM mit Administratorrechten installiert?
      Es gibt auf diesem Notebook nur einen Benutzer und das ist der Admin.
      Nichts desto trotz habe ich die Applikation auch nochmals als ausführender Admin drüber "gebügelt".

      tschoeatsch wrote:

      ...bascom-avr.xml - Lösch die mal
      Abgesehen davon, dass dieses Notebook BasCom vorher noch nie "gesehen" hatte habe ich auch das versucht.

      Nützt aber leider auch nichts.
      Auch das spezielle Ausführen der installierten EXE als Admin bringt natürlich nichts :whistling:
      Ich fürchte da eher eine HW-inkompatibilität (Windows ist auf jeden Fall ganz aktuell (V 1803 von gestern)
    • Michael wrote:

      ... Wechselmediums ...
      Ich habe BasCom jetzt auf das Laufwerk C (was ja in diesem Notebook im Gegensatz zu Laufwerk D kein Wechselmedium ist) installiert.
      Die Installation erfolgte am Laufwerk C in einen Ordner der außerhalb von "Programme" liegt im Hauptverzeichnis weil das ja auch Probleme (wenn auch andere) machen würde.
      Genau so ist BasCom übrigens auch auf meinem Desktop installiert wo das ganze auch klaglos funktioniert.
      Am Notebook hat aber auch das nicht funktioniert und bringt ebenfalls den oben beschriebenen Fehler.
      Weiß eventuell wer auf welcher Basis BasCom programmiert wurde?
    • Zitronenfalter wrote:

      Die Installation erfolgte am Laufwerk C in einen Ordner der außerhalb von "Programme" liegt im Hauptverzeichnis weil das ja auch Probleme (wenn auch andere) machen würde.
      ja, weil der Samples-Ordner und der Lib-Ordner im Admin-geschütztem Programme Ordner liegt. Bei der Installation und für die Funktion von Bascom selbst macht das aber nichts aus.


      Zitronenfalter wrote:

      Genau so ist BasCom übrigens auch auf meinem Desktop installiert wo das ganze auch klaglos funktioniert.
      Am Notebook hat aber auch das nicht funktioniert und bringt ebenfalls den oben beschriebenen Fehler.
      Weiß eventuell wer auf welcher Basis BasCom programmiert wurde?
      Es könnten Reste von der Wechselmedium-Installation sein.
      Laut dem Log oben ist wohl Pascal verwendet worden (Delphi?)
      Hier habe ich ein ähnliches Fehlerbild gefunden, da lag es wohl an Delphi:
      github.com/bitdump/BLHeli/issues/199
    • Michael wrote:

      ... da lag es wohl an Delphi:
      Ich denke auch, dass es in diese Richtung gehen wird. Bei alten mit AutoIt erstellten EXE meldet der Windows-Defender auch plötzlich einen gefährlichen Virus.
      Kompiliert man das mit einem aktuellen Autoit ist der Virus auch wieder weg a_67_e210de67 .
      Da ich mit dem Notebook ohnehin eher wenig entwickeln werde (dazu ist mir der Bildschirm nicht groß genug :whistling: ) sondern das Hauptanwendungsgebiet nur das flashen, auslesen oder Konfigurieren von bereits bestehenden Baugruppen sein wird, welche mit einem Desktop dann nicht (mehr) leicht erreicht werden können, werde ich das dabei belassen und nicht weiter verfolgen. Denn zumindest das funktioniert soweit wenn auch nur mit einem mySmartUSB light oder eben entsprechenden Schnittstellenadaptern :D .
    • Hallo,
      ich habe jetzt das gleiche Problem, d.h. die Fehlermeldung
      Exception class: EControllerError
      Exception message: Device cannot be opened.
      Exception address: 009F7914
      Die Historie ist die:
      Kürzlich, nach längerer Bascom-Enthaltsamkeit, startete Bascom 2080 und 2081gar nicht mehr (Win10),
      "Die Anwendung konnte nicht korrekt gestartet werden (0xc0000005)", ok und weg war es.
      Im MCS-Forum nachgeschaut:
      mcselec.com/index2.php?option=…&postorder=asc&highlight=
      Von Mark zuerst allgemeine Hilfe, dann wurde er persönlich und hat das Thema geschlossen und wollte das Thema nur noch per email weiterführen.... Warum wohl?
      Dabei stellte sich auch heraus, dass zwei User drastisch unterschiedliche Installationen des älteren Bascom 2079 bekommen hatten....
      Übrigens ist das Thema dort eines der meistgelesenen.

      Ich habe fast eine Woche lang versucht, das Programm wieder zum Laufen zu bringen, aber erfolglos.
      Nun kam glücklicherweise das 1809-Update von Windows 10 heraus, und siehe da, Bascom 2081 läuft wieder, allerdings nun mit der oben angegebenen Fehlermeldung. Es scheint aber so zu sein, dass das Programm trotzdem richtig funktioniert (wahrscheinlich wird irgendeiner der HID-Programmer nicht laufen, aber die benutze ich eh nicht).
      Falls jemand eine Idee hat, wie man die Fehlermeldung wegkriegt, lasse er es mich freundlicherweise wissen...
      Gruß, elektron
    • Also ich hatte von Anfang an keine Probleme mit Bascom unter Windows 10 64 Bit.
      Allerdings habe ich es auch auf der zweiten HDD installiert die in meinem MSI Laptop drin ist.
      Das einzige was ab und zu mal passiert ist, dass Bascom nicht startet bzw sehr lange zum starten braucht.
      Jetzt starte ich es immer als Admin und seit dem läuft auch alles bestens.
      Eine Lösung habe ich nicht, aber mir gefällt Ihr Problem.
    • djmsc wrote:

      Jetzt starte ich es immer als Admin und seit dem läuft auch alles bestens.
      Das hilft aber bei dem oben genannten Fehler nicht.
      Ich vermute, es fehlt irgendeine Datei oder ein Registry-link, möglicherweise durch eine Aufräumaktion verursacht.
      Ich hatte mal CC-Cleaner benutzt und Bascom dann aber längere Zeit nicht.... (Aber Zurückspielen älterer Registry-Backups half nicht).
      Immerhin hatte das Upgrade auf 1809 den heilsamen Effekt (es ist praktisch eine völlige Neuinstallation mit Zurückspielen aller installierten Programme), dass 2081-Bascom wieder lief, was es vorher gar nicht mehr tat, allerdings eben mit der besagten nervigen Fehlermeldung.
    • elektron wrote:

      Das hilft aber bei dem oben genannten Fehler nicht.

      djmsc wrote:

      Jetzt starte ich es immer als Admin und seit dem läuft auch alles bestens.
      Das bezog sich auf den vorherigen Satz

      djmsc wrote:

      Das einzige was ab und zu mal passiert ist, dass Bascom nicht startet bzw sehr lange zum starten braucht.
      Eine Lösung habe ich nicht, aber mir gefällt Ihr Problem.