Ist an der Forumssoftware was verstellt? Das Absenden von Antworten geht manchmal nur über die 'erweiterte Bearbeitung'

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • stefanhamburg wrote:

      Jetzt probiere ich einmal einen Beitrag ohne erweiterten Editor.
      Probier auch gleich mal bascom-formatierten code mit Kommentaren
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------
    • BASCOM Source Code

      1. Do
      2. Adc_wert = Getadc(0)
      3. Select Case Adc_wert
      4. Case 165 To 175 : 'Taste runter
      5. Case 335 To 345 : 'Taste Rechts
      6. Waitms 150
      7. Incr Stelle
      8. If Stelle = 64 Then Stelle = 63
      9. Gosub Set_stelle
      10. Case 500 To 510 : 'Enter Taste
      11. Case 670 To 680 : 'Taste Links
      12. Waitms 150
      13. Decr Stelle
      14. If Stelle = 255 Then Stelle = 0
      15. Gosub Set_stelle
      16. Case 840 To 850 : 'Taste Hoch
      17. End Select
      18. Loop
      19. End
      20. 'Dies ist ein Kommentar :-)
      Display All
      Stimmt Kommentare werden nicht angezeigt obwohl welche drin stehen.
      Und wenn ich nochmal auf editieren gehe sehe ich die Kommentare auch wieder.
      Eine Lösung habe ich nicht, aber mir gefällt Ihr Problem.
    • Testcode:


      BASCOM Source Code

      1. '-----------------------------------------------------------------------------------------
      2. 'name : case.bas
      3. 'copyright : (c) 1995-2005, MCS Electronics
      4. 'purpose : demonstrates SELECT CASE statement
      5. 'micro : Mega48
      6. 'suited for demo : yes
      7. 'commercial addon needed : no
      8. '-----------------------------------------------------------------------------------------
      9. $regfile = "m48def.dat" ' specify the used micro
      10. $crystal = 4000000 ' used crystal frequency
      11. $baud = 19200 ' use baud rate
      12. $hwstack = 32 ' default use 32 for the hardware stack
      13. $swstack = 10 ' default use 10 for the SW stack
      14. $framesize = 40 ' default use 40 for the frame space
      15. Dim I As Byte 'dim variable
      16. Dim S As String * 5 , Z As String * 5
      17. Do
      18. Input "Enter value (0-255) " , I
      19. Select Case I
      20. Case 1 : Print "1"
      21. Case 2 : Print "2"
      22. Case 3 To 5 : Print "3-5"
      23. Case Is >= 10 : Print ">= 10"
      24. Case Else : Print "Not in Case statement"
      25. End Select
      26. Loop
      27. End
      28. 'note that a Boolean expression like > 3 must be preceded
      29. 'by the IS keyword
      Display All
      Kommentarzeilen werden nicht formatiert angezeigt, sind aber nicht weg. Wenn ich den Beitrag editiere, dann sind die Kommentarzeilen da.
    • djmsc wrote:

      BASCOM Source Code

      1. Do
      2. Adc_wert = Getadc(0)
      3. Select Case Adc_wert
      4. Case 165 To 175 : 'Taste runter
      5. Case 335 To 345 : 'Taste Rechts
      6. Waitms 150
      7. Incr Stelle
      8. If Stelle = 64 Then Stelle = 63
      9. Gosub Set_stelle
      10. Case 500 To 510 : 'Enter Taste
      11. Case 670 To 680 : 'Taste Links
      12. Waitms 150
      13. Decr Stelle
      14. If Stelle = 255 Then Stelle = 0
      15. Gosub Set_stelle
      16. Case 840 To 850 : 'Taste Hoch
      17. End Select
      18. Loop
      19. End
      20. 'Dies ist ein Kommentar :-)
      Display All
      Stimmt Kommentare werden nicht angezeigt obwohl welche drin stehen.
      Und wenn ich nochmal auf editieren gehe sehe ich die kommentare auch wieder.
      Na das ist ja toll, wenn ich Deinen Beitrag zitiere, sehe ich nicht nur den Code, sondern auch Deinen Post rolling:
      Wenn das die Lösung ist, möchte ich mein Problem wieder haben.
    • ceperiga wrote:

      djmsc wrote:

      BASCOM Source Code

      1. Do
      2. Adc_wert = Getadc(0)
      3. Select Case Adc_wert
      4. Case 165 To 175 : 'Taste runter
      5. Case 335 To 345 : 'Taste Rechts
      6. Waitms 150
      7. Incr Stelle
      8. If Stelle = 64 Then Stelle = 63
      9. Gosub Set_stelle
      10. Case 500 To 510 : 'Enter Taste
      11. Case 670 To 680 : 'Taste Links
      12. Waitms 150
      13. Decr Stelle
      14. If Stelle = 255 Then Stelle = 0
      15. Gosub Set_stelle
      16. Case 840 To 850 : 'Taste Hoch
      17. End Select
      18. Loop
      19. End
      20. 'Dies ist ein Kommentar :-)
      Display All
      Stimmt Kommentare werden nicht angezeigt obwohl welche drin stehen.
      Und wenn ich nochmal auf editieren gehe sehe ich die kommentare auch wieder.
      Na das ist ja toll, wenn ich Deinen Beitrag zitiere, sehe ich nicht nur den Code, sondern auch Deinen Post rolling:
      Logisch, updates verbessern alles.
      Raum für Notizen

      -----------------------------------------------------------------------------------------------------

      -----------------------------------------------------------------------------------------------------
    • Eine Forumsoftware ist immer beliebtes Angriffsziel für Hacker, weil man viele User auf einmal "am Wickel" hat. Von daher bin ich froh, dass bekannte Sicherheitslücken durch regelmäßige Updates geschlossen werden. Dabei kann durchaus mal was schiefgehen. Wenn beim Programmieren immer alles glatt laufen würde, hätte sich ein Großteil unseres Forums erledigt. Wir finden ja auch immer eine Lösung und genauso wird das mit unserem derzeitigen "kleinen Fehler" sein.
      Wenn das die Lösung ist, möchte ich mein Problem wieder haben.
    • ist echt eine Ausnahmesituation, wenn mann von 50 Paar Kuhaugen angeschaut wird mit der Gedankenblase daneben:" Und nun?Mach was..."
      Hatte ich auch gerade wieder Montag in der Firma.
      Da ging nach einem Windows-Einspieler mal wieder nix, aber nur auf 30 von 50 Rechnern, super!
      "Authentifizierungsfehler am Server"
      Am Ende war "nix Fehler", die zwei Datenbankanwendungen, die ich seit 20 Jahren entwickle, mussten neu installiert werden weil MS irgend was in der Registry gespielt hatte...DANKE!

      ALSO: DAS SCHAFFST DU SCHON, ICH WEISS, BIS DAS DING DURCH IST DENKT MAN AN NICHTS ANDERES.
      KOPF HOCH UND RAN AN DEN SPECK!

      Gruss und Glückauf

      Peer
    • Peer,
      das Forum wird mit einer "richtigen Datenbank", MYSQL betrieben.
      Mit dem von dir beschriebenen Verfahren, Daten zu schreiben, würde hier fast nichts funktionieren. Die Daten werden im RAM gehalten und mit den Daten der Platte synchronisiert.

      Ich entwickle ebenfalls mit MYSQL DB und die Clientsoftware ist mit Delphi, Lazarus oder als Webfrontend in PHP erstellt und bin heilfroh, nicht so sehr von Microsoft abhängig zu sein.

      Die Scripte für Quellcode Darstellung habe ich erstellt, aber die liefen vor dem Update... darum spiele ich im Moment nicht am System herum.
      Da soll erst mal BB nachsehen, was sie verzapft haben :D
      Code first, think later - Natural programmer :D